mirror of
https://github.com/crosstool-ng/crosstool-ng.git
synced 2024-12-25 23:41:05 +00:00
29b6e00368
https://sourceware.org/pipermail/binutils/2022-August/122246.html Add binutils 2.39 and regenerate patches. 0008-binutils-2.38-vs.-ppc32-linux-kernel.patch is dropped as it has been applied upstream. Add a milestone for 2.39 which will be handy for Loongarch. Binutils now requires bison >= 3.0.4 to build gprofng for x86/aarch64 so we build our own bison when the host bison does not meet that requirement (which appears to be the case on macOS). Signed-off-by: Chris Packham <judge.packham@gmail.com>
111 lines
2.6 KiB
Diff
111 lines
2.6 KiB
Diff
From 4afcbb7decf230fdf7a02a5fe9dd1b5dfaab5712 Mon Sep 17 00:00:00 2001
|
|
From: Chris Packham <judge.packham@gmail.com>
|
|
Date: Mon, 8 Aug 2022 20:37:24 +1200
|
|
Subject: [PATCH] Don't link to libfl as it's unnecessary
|
|
|
|
---
|
|
binutils/configure | 3 +++
|
|
binutils/configure.ac | 3 +++
|
|
gas/configure | 3 +++
|
|
gas/configure.ac | 3 +++
|
|
ld/configure | 3 +++
|
|
ld/configure.ac | 3 +++
|
|
6 files changed, 18 insertions(+)
|
|
|
|
--- a/binutils/configure
|
|
+++ b/binutils/configure
|
|
@@ -12289,6 +12289,7 @@
|
|
done
|
|
test -n "$YACC" || YACC="yacc"
|
|
|
|
+save_LIBS=$LIBS
|
|
for ac_prog in flex lex
|
|
do
|
|
# Extract the first word of "$ac_prog", so it can be a program name with args.
|
|
@@ -12452,6 +12453,8 @@
|
|
if test "$LEX" = :; then
|
|
LEX=${am_missing_run}flex
|
|
fi
|
|
+LIBS=$save_LIBS
|
|
+LEXLIB=
|
|
|
|
ALL_LINGUAS="bg ca da es fi fr hr id it ja pt ro ru rw sk sr sv tr uk vi zh_CN zh_TW"
|
|
# If we haven't got the data from the intl directory,
|
|
--- a/binutils/configure.ac
|
|
+++ b/binutils/configure.ac
|
|
@@ -137,7 +137,10 @@
|
|
fi
|
|
|
|
AC_PROG_YACC
|
|
+save_LIBS=$LIBS
|
|
AM_PROG_LEX
|
|
+LIBS=$save_LIBS
|
|
+LEXLIB=
|
|
|
|
ALL_LINGUAS="bg ca da es fi fr hr id it ja pt ro ru rw sk sr sv tr uk vi zh_CN zh_TW"
|
|
ZW_GNU_GETTEXT_SISTER_DIR
|
|
--- a/gas/configure
|
|
+++ b/gas/configure
|
|
@@ -12932,6 +12932,7 @@
|
|
done
|
|
test -n "$YACC" || YACC="yacc"
|
|
|
|
+save_LIBS=$LIBS
|
|
for ac_prog in flex lex
|
|
do
|
|
# Extract the first word of "$ac_prog", so it can be a program name with args.
|
|
@@ -13095,6 +13096,8 @@
|
|
if test "$LEX" = :; then
|
|
LEX=${am_missing_run}flex
|
|
fi
|
|
+LIBS=$save_LIBS
|
|
+LEXLIB=
|
|
|
|
ALL_LINGUAS="es fi fr id ja ru rw sv tr uk zh_CN"
|
|
# If we haven't got the data from the intl directory,
|
|
--- a/gas/configure.ac
|
|
+++ b/gas/configure.ac
|
|
@@ -933,7 +933,10 @@
|
|
AC_DEFINE_UNQUOTED(TARGET_OS, "${target_os}", [Target OS.])
|
|
|
|
AC_PROG_YACC
|
|
+save_LIBS=$LIBS
|
|
AM_PROG_LEX
|
|
+LIBS=$save_LIBS
|
|
+LEXLIB=
|
|
|
|
ALL_LINGUAS="es fi fr id ja ru rw sv tr uk zh_CN"
|
|
ZW_GNU_GETTEXT_SISTER_DIR
|
|
--- a/ld/configure
|
|
+++ b/ld/configure
|
|
@@ -16448,6 +16448,7 @@
|
|
done
|
|
test -n "$YACC" || YACC="yacc"
|
|
|
|
+save_LIBS=$LIBS
|
|
for ac_prog in flex lex
|
|
do
|
|
# Extract the first word of "$ac_prog", so it can be a program name with args.
|
|
@@ -16611,6 +16612,8 @@
|
|
if test "$LEX" = :; then
|
|
LEX=${am_missing_run}flex
|
|
fi
|
|
+LIBS=$save_LIBS
|
|
+LEXLIB=
|
|
|
|
|
|
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking whether to enable maintainer-specific portions of Makefiles" >&5
|
|
--- a/ld/configure.ac
|
|
+++ b/ld/configure.ac
|
|
@@ -346,7 +346,10 @@
|
|
AC_EXEEXT
|
|
|
|
AC_PROG_YACC
|
|
+save_LIBS=$LIBS
|
|
AM_PROG_LEX
|
|
+LIBS=$save_LIBS
|
|
+LEXLIB=
|
|
|
|
AM_MAINTAINER_MODE
|
|
AM_CONDITIONAL(GENINSRC_NEVER, false)
|