mirror of
https://github.com/crosstool-ng/crosstool-ng.git
synced 2024-12-25 15:31:05 +00:00
a4cff7a061
Otherwise, it tries to link against libgcc_eh which is not available until the final compiler (or previously, the pass-2 compiler) is built. Signed-off-by: Alexey Neyman <stilor@att.net>
32 lines
919 B
Diff
32 lines
919 B
Diff
commit 95f5a9a866695da4e038aa4e6ccbbfd5d9cf63b7
|
|
Author: Joseph Myers <joseph@codesourcery.com>
|
|
Date: Tue Jul 3 19:14:59 2012 +0000
|
|
|
|
Avoid use of libgcc_s and libgcc_eh when building glibc.
|
|
|
|
---
|
|
sysdeps/arm/eabi/Makefile | 8 ++++++++
|
|
1 file changed, 8 insertions(+)
|
|
|
|
--- a/sysdeps/arm/eabi/Makefile
|
|
+++ b/sysdeps/arm/eabi/Makefile
|
|
@@ -1,3 +1,6 @@
|
|
+gnulib-arch = $(elfobjdir)/libgcc-stubs.a
|
|
+static-gnulib-arch = $(elfobjdir)/libgcc-stubs.a
|
|
+
|
|
ifeq ($(subdir),csu)
|
|
aeabi_constants = aeabi_lcsts aeabi_sighandlers aeabi_math
|
|
aeabi_routines = aeabi_assert aeabi_localeconv aeabi_errno_addr \
|
|
@@ -24,6 +27,11 @@
|
|
sysdep_routines += aeabi_unwind_cpp_pr1 find_exidx
|
|
shared-only-routines += aeabi_unwind_cpp_pr1
|
|
sysdep-rtld-routines += aeabi_unwind_cpp_pr1
|
|
+
|
|
+$(objpfx)libgcc-stubs.a: $(objpfx)aeabi_unwind_cpp_pr1.os
|
|
+ $(build-extra-lib)
|
|
+
|
|
+lib-noranlib: $(objpfx)libgcc-stubs.a
|
|
endif
|
|
|
|
ifeq ($(subdir),math)
|