mirror of
https://github.com/crosstool-ng/crosstool-ng.git
synced 2025-01-06 04:54:09 +00:00
5463ab4bf6
In GDB 10.x gdbserver was promoted to the top-level folder, see https://sourceware.org/git/?p=binutils-gdb.git;a=commit;h=919adfe8409211c726c1d05b47ca59890ee648f1 Which means it is no longer a subfolder in "gdb" and so we have to build gdbserver now exactly in the same way as normal native GDB. One interesting detail is gdbserver doesn't need to deal with target description in .xml so it doesn't depend on libexpat on target, thus we need to move libexpat explicit selection from do_gdb_backend() to its callers when building native [full] gdb as well as cross-gdb for the host. Signed-off-by: Alexey Brodkin <abrodkin@synopsys.com> [cp: support old/new layout, regenerate patches] Signed-off-by: Chris Packham <judge.packham@gmail.com>
46 lines
1.7 KiB
Diff
46 lines
1.7 KiB
Diff
---
|
|
gdb/gdbserver/configure | 11 -----------
|
|
gdb/gdbserver/configure.ac | 11 -----------
|
|
2 files changed, 22 deletions(-)
|
|
|
|
--- a/gdbserver/configure
|
|
+++ b/gdbserver/configure
|
|
@@ -10069,17 +10069,6 @@
|
|
|
|
|
|
case "${target}" in
|
|
- *-android*)
|
|
- # Starting with NDK version 9, <elf.h> actually includes definitions
|
|
- # of Elf32_auxv_t and Elf64_auxv_t. But sadly, <elf.h> includes
|
|
- # <sys/exec_elf.h> which defines some of the ELF types incorrectly,
|
|
- # leading to conflicts with the defintions from <linux/elf.h>.
|
|
- # This makes it impossible for us to include both <elf.h> and
|
|
- # <linux/elf.h>, which means that, in practice, we do not have
|
|
- # access to Elf32_auxv_t and Elf64_auxv_t on this platform.
|
|
- # Therefore, do not try to auto-detect availability, as it would
|
|
- # get it wrong on this platform.
|
|
- ;;
|
|
*)
|
|
ac_fn_c_check_type "$LINENO" "Elf32_auxv_t" "ac_cv_type_Elf32_auxv_t" "#include <elf.h>
|
|
|
|
--- a/gdbserver/configure.ac
|
|
+++ b/gdbserver/configure.ac
|
|
@@ -155,17 +155,6 @@
|
|
])
|
|
|
|
case "${target}" in
|
|
- *-android*)
|
|
- # Starting with NDK version 9, <elf.h> actually includes definitions
|
|
- # of Elf32_auxv_t and Elf64_auxv_t. But sadly, <elf.h> includes
|
|
- # <sys/exec_elf.h> which defines some of the ELF types incorrectly,
|
|
- # leading to conflicts with the defintions from <linux/elf.h>.
|
|
- # This makes it impossible for us to include both <elf.h> and
|
|
- # <linux/elf.h>, which means that, in practice, we do not have
|
|
- # access to Elf32_auxv_t and Elf64_auxv_t on this platform.
|
|
- # Therefore, do not try to auto-detect availability, as it would
|
|
- # get it wrong on this platform.
|
|
- ;;
|
|
*)
|
|
AC_CHECK_TYPES([Elf32_auxv_t, Elf64_auxv_t], [], [],
|
|
#include <elf.h>
|