crosstool-ng/packages/ltrace/0.7.3/001-avoid-libstdc++.patch
Alexey Neyman e7deac3aad Switch comp.libs/tools and debug to new framework.
Signed-off-by: Alexey Neyman <stilor@att.net>
2017-07-08 10:57:56 -07:00

44 lines
1004 B
Diff

From: Juan Cespedes <cespedes@debian.org>
Description: avoid warning from dpkg-shlibdeps:
package could avoid a useless dependency if ltrace was not
linked against libstdc++.so.6 (it uses none of the library's symbols)
Last-Update: 2013-12-30
--- a/configure.ac 2013-09-17 01:04:28.000000000 +0200
+++ b/configure.ac 2013-12-30 12:24:20.000000000 +0100
@@ -113,6 +113,15 @@
libstdcxx_LIBS=""])
AC_SUBST(libstdcxx_LIBS)
+if test "x$liberty_LIBS" != "x"
+then
+ libsupcxx_LIBS=""
+ libstdcxx_LIBS=""
+elif test "x$libsupcxx_LIBS" != "x"
+then
+ libstdcxx_LIBS=""
+fi
+
dnl Check security_get_boolean_active availability.
AC_CHECK_HEADERS(selinux/selinux.h)
--- a/configure 2013-09-17 01:07:46.000000000 +0100
+++ b/configure 2013-12-30 12:34:23.000000000 +0100
@@ -11826,6 +11826,15 @@
+if test "x$liberty_LIBS" != "x"
+then
+ libsupcxx_LIBS=""
+ libstdcxx_LIBS=""
+elif test "x$libsupcxx_LIBS" != "x"
+then
+ libstdcxx_LIBS=""
+fi
+
for ac_header in selinux/selinux.h
do :