mirror of
https://github.com/crosstool-ng/crosstool-ng.git
synced 2024-12-19 04:47:52 +00:00
86c2982568
This refreshes the line numbers, removes any fuzz (which would make any future forward ports easier) and standardizes the patch/file headers (which makes them easier to read). Signed-off-by: Alexey Neyman <stilor@att.net>
72 lines
2.6 KiB
Diff
72 lines
2.6 KiB
Diff
# commit 8f9ebb08af1368962d9f24c4cfacb55cf8eee560
|
|
# Author: Alan Modra <amodra@gmail.com>
|
|
# Date: Thu Oct 3 14:03:03 2013 +0930
|
|
#
|
|
# PowerPC LE configury
|
|
# http://sourceware.org/ml/libc-alpha/2013-08/msg00096.html
|
|
#
|
|
# This adds the basic configury bits for powerpc64le and powerpcle.
|
|
#
|
|
# * configure.in: Map powerpc64le and powerpcle to base_machine/machine.
|
|
# * configure: Regenerate.
|
|
# * nptl/shlib-versions: Powerpc*le starts at 2.18.
|
|
# * shlib-versions: Likewise.
|
|
#
|
|
# commit 0ff8246327401ae8779e2697d5c7348611cdbf8a
|
|
# Author: Adhemerval Zanella <azanella@linux.vnet.ibm.com>
|
|
# Date: Tue Feb 4 09:49:08 2014 -0200
|
|
#
|
|
# PowerPC: Change powerpc64le start ABI to 2.17.
|
|
#
|
|
---
|
|
# configure | 4 ++--
|
|
# configure.in | 4 ++--
|
|
# nptl/shlib-versions | 1 +
|
|
# shlib-versions | 1 +
|
|
# 4 files changed, 6 insertions(+), 4 deletions(-)
|
|
#
|
|
--- a/configure
|
|
+++ b/configure
|
|
@@ -4176,8 +4176,8 @@
|
|
# base_machine, we don't change it.
|
|
test -n "$base_machine" || case "$machine" in
|
|
i[34567]86) base_machine=i386 machine=i386/$machine ;;
|
|
-powerpc) base_machine=powerpc machine=powerpc/powerpc32 ;;
|
|
-powerpc64) base_machine=powerpc machine=powerpc/powerpc64 ;;
|
|
+powerpc64*) base_machine=powerpc machine=powerpc/powerpc64 ;;
|
|
+powerpc*) base_machine=powerpc machine=powerpc/powerpc32 ;;
|
|
s390) base_machine=s390 machine=s390/s390-32 ;;
|
|
s390x) base_machine=s390 machine=s390/s390-64 ;;
|
|
sh3*) base_machine=sh machine=sh/sh3 ;;
|
|
--- a/configure.in
|
|
+++ b/configure.in
|
|
@@ -539,8 +539,8 @@
|
|
# base_machine, we don't change it.
|
|
test -n "$base_machine" || case "$machine" in
|
|
i[34567]86) base_machine=i386 machine=i386/$machine ;;
|
|
-powerpc) base_machine=powerpc machine=powerpc/powerpc32 ;;
|
|
-powerpc64) base_machine=powerpc machine=powerpc/powerpc64 ;;
|
|
+powerpc64*) base_machine=powerpc machine=powerpc/powerpc64 ;;
|
|
+powerpc*) base_machine=powerpc machine=powerpc/powerpc32 ;;
|
|
s390) base_machine=s390 machine=s390/s390-32 ;;
|
|
s390x) base_machine=s390 machine=s390/s390-64 ;;
|
|
sh3*) base_machine=sh machine=sh/sh3 ;;
|
|
--- a/nptl/shlib-versions
|
|
+++ b/nptl/shlib-versions
|
|
@@ -2,4 +2,5 @@
|
|
sh.*-.*-linux.* libpthread=0 GLIBC_2.2
|
|
s390x-.*-linux.* libpthread=0 GLIBC_2.2
|
|
powerpc64-.*-linux.* libpthread=0 GLIBC_2.3
|
|
+powerpc.*le-.*-linux.* libpthread=0 GLIBC_2.17
|
|
.*-.*-linux.* libpthread=0
|
|
--- a/shlib-versions
|
|
+++ b/shlib-versions
|
|
@@ -23,6 +23,7 @@
|
|
|
|
s390x-.*-linux.* DEFAULT GLIBC_2.2
|
|
powerpc64-.*-linux.* DEFAULT GLIBC_2.3
|
|
+powerpc.*le-.*-linux.* DEFAULT GLIBC_2.17
|
|
.*-.*-gnu-gnu.* DEFAULT GLIBC_2.2.6
|
|
|
|
# Configuration ABI Identifier for ABI data files
|