mirror of
https://github.com/crosstool-ng/crosstool-ng.git
synced 2024-12-21 05:43:09 +00:00
878a16a13a
Brings in the following changes - Fix a bug when getting a gzip header extra field with inflateGetHeader(). This remedies CVE-2022-37434. - Fix a bug in block type selection when Z_FIXED used. Now the smallest block type is selected, for better compression. - Fix a configure issue that discarded the provided CC definition. - Correct incorrect inputs provided to the CRC functions. This mitigates a bug in Java. - Repair prototypes and exporting of the new CRC functions. - Fix inflateBack to detect invalid input with distances too far. Mark zlib-1.2.12 as obsolete. Signed-off-by: Chris Packham <judge.packham@gmail.com>
29 lines
930 B
Diff
29 lines
930 B
Diff
---
|
|
win32/Makefile.gcc | 8 ++++++--
|
|
1 file changed, 6 insertions(+), 2 deletions(-)
|
|
|
|
--- a/win32/Makefile.gcc
|
|
+++ b/win32/Makefile.gcc
|
|
@@ -66,7 +66,11 @@
|
|
gzwrite.o infback.o inffast.o inflate.o inftrees.o trees.o uncompr.o zutil.o
|
|
OBJA =
|
|
|
|
-all: $(STATICLIB) $(SHAREDLIB) $(IMPLIB) example.exe minigzip.exe example_d.exe minigzip_d.exe
|
|
+all: $(STATICLIB) example.exe minigzip.exe
|
|
+
|
|
+ifeq ($(SHARED_MODE),1)
|
|
+all: $(SHAREDLIB) $(IMPLIB) example_d.exe minigzip_d.exe
|
|
+endif
|
|
|
|
test: example.exe minigzip.exe
|
|
./example
|
|
@@ -120,7 +124,7 @@
|
|
.PHONY: install uninstall clean
|
|
|
|
install: zlib.h zconf.h $(STATICLIB) $(IMPLIB)
|
|
- @if test -z "$(DESTDIR)$(INCLUDE_PATH)" -o -z "$(DESTDIR)$(LIBRARY_PATH)" -o -z "$(DESTDIR)$(BINARY_PATH)"; then \
|
|
+ @if test -z "$(INCLUDE_PATH)" -o -z "$(LIBRARY_PATH)" -o -z "$(BINARY_PATH)"; then \
|
|
echo INCLUDE_PATH, LIBRARY_PATH, and BINARY_PATH must be specified; \
|
|
exit 1; \
|
|
fi
|