mirror of
https://github.com/crosstool-ng/crosstool-ng.git
synced 2024-12-28 00:28:52 +00:00
8d3f0a8781
- add a framework to easily add new ones - add gdb as a first debug facility - add patches for gdb After the kernel checked its installed headers, clean up the mess of .checked.* files. Reorder scripts/crosstool.sh: - dump the configuration early - renice early - get info about build system early, when setting up the environment - when in cross or native, the host tools are those of the build system, and only in this case - elapsed time calculations moved to scripts/functions Remove handling of the color: it's gone once and for all. Update tools/addToolVersion.sh: - handle debug facilities - commonalise some code - remove dead tools (cygwin, tcc) Point to my address for bug reports.
54 lines
2.2 KiB
Diff
54 lines
2.2 KiB
Diff
Fix some missing uses of DESTDIR in the sim/ directories. The Debian
|
|
packages use DESTDIR to build.
|
|
|
|
%patch
|
|
Index: gdb-6.3/sim/Makefile.in
|
|
===================================================================
|
|
--- gdb-6.3.orig/sim/Makefile.in 2003-09-03 14:46:52.000000000 -0400
|
|
+++ gdb-6.3/sim/Makefile.in 2004-11-10 00:39:25.381315738 -0500
|
|
@@ -93,6 +93,7 @@ FLAGS_TO_PASS = \
|
|
"CC=$(CC)" \
|
|
"CC_FOR_BUILD=$(CC_FOR_BUILD)" \
|
|
"CFLAGS=$(CFLAGS)" \
|
|
+ "DESTDIR=$(DESTDIR)" \
|
|
"RANLIB=$(RANLIB)" \
|
|
"MAKEINFO=$(MAKEINFO)" \
|
|
"INSTALL=$(INSTALL)" \
|
|
Index: gdb-6.3/sim/common/Make-common.in
|
|
===================================================================
|
|
--- gdb-6.3.orig/sim/common/Make-common.in 2003-09-08 13:24:59.000000000 -0400
|
|
+++ gdb-6.3/sim/common/Make-common.in 2004-11-10 00:39:25.383315347 -0500
|
|
@@ -581,14 +581,14 @@ install: install-common $(SIM_EXTRA_INST
|
|
|
|
install-common: installdirs
|
|
n=`echo run | sed '$(program_transform_name)'`; \
|
|
- $(INSTALL_PROGRAM) run$(EXEEXT) $(bindir)/$$n$(EXEEXT)
|
|
+ $(INSTALL_PROGRAM) run$(EXEEXT) $(DESTDIR)$(bindir)/$$n$(EXEEXT)
|
|
n=`echo libsim.a | sed s/libsim.a/lib$(target_alias)-sim.a/`; \
|
|
- $(INSTALL_DATA) libsim.a $(libdir)/$$n ; \
|
|
- ( cd $(libdir) ; $(RANLIB) $$n )
|
|
+ $(INSTALL_DATA) libsim.a $(DESTDIR)$(libdir)/$$n ; \
|
|
+ ( cd $(DESTDIR)$(libdir) ; $(RANLIB) $$n )
|
|
|
|
installdirs:
|
|
- $(SHELL) $(srcdir)/../../mkinstalldirs $(bindir)
|
|
- $(SHELL) $(srcdir)/../../mkinstalldirs $(libdir)
|
|
+ $(SHELL) $(srcdir)/../../mkinstalldirs $(DESTDIR)$(bindir)
|
|
+ $(SHELL) $(srcdir)/../../mkinstalldirs $(DESTDIR)$(libdir)
|
|
|
|
check:
|
|
cd ../testsuite && $(MAKE) check RUNTESTFLAGS="$(RUNTESTFLAGS)"
|
|
Index: gdb-6.3/sim/erc32/Makefile.in
|
|
===================================================================
|
|
--- gdb-6.3.orig/sim/erc32/Makefile.in 2000-03-07 10:32:49.000000000 -0500
|
|
+++ gdb-6.3/sim/erc32/Makefile.in 2004-11-10 00:39:25.385314957 -0500
|
|
@@ -53,7 +53,7 @@ end.h: end
|
|
# Copy the files into directories where they will be run.
|
|
install-sis: installdirs
|
|
n=`echo sis | sed '$(program_transform_name)'`; \
|
|
- $(INSTALL_PROGRAM) sis$(EXEEXT) $(bindir)/$$n$(EXEEXT)
|
|
+ $(INSTALL_PROGRAM) sis$(EXEEXT) $(DESTDIR)$(bindir)/$$n$(EXEEXT)
|
|
|
|
clean-sis:
|
|
rm -f sis end end.h
|