crosstool-ng/packages/glibc-ports/2.15/0001-libmemusage-link-failure.patch
Alexey Neyman 98bc4decde Run all patches through renumbering and update
Signed-off-by: Alexey Neyman <stilor@att.net>
2017-12-02 12:44:39 -08:00

22 lines
547 B
Diff

commit 2d80bda39073a35af4b904d27fa1511cd309b26f
Author: Nathan Sidwell <nathan@codesourcery.com>
Date: Fri Jan 6 20:14:44 2012 +0000
Add ARM dependency of libmemusage.so on libc_nonshared.a.
---
sysdeps/arm/Makefile | 5 +++++
1 file changed, 5 insertions(+)
--- a/sysdeps/arm/Makefile
+++ b/sysdeps/arm/Makefile
@@ -7,3 +7,8 @@
ifeq ($(subdir),csu)
gen-as-const-headers += tlsdesc.sym
endif
+
+# to pull in __aeabi_read_tp, needed for tls
+ifeq ($(subdir),malloc)
+$(objpfx)libmemusage.so: $(common-objpfx)libc_nonshared.a
+endif