mirror of
https://github.com/crosstool-ng/crosstool-ng.git
synced 2024-12-19 21:07:54 +00:00
98bc4decde
Signed-off-by: Alexey Neyman <stilor@att.net>
28 lines
788 B
Diff
28 lines
788 B
Diff
If we're using a cvs snapshot which updates the source files, and
|
|
perl isn't installed yet, then we can't regen the docs. Not a big
|
|
deal, so just whine a little and continue on our merry way.
|
|
|
|
http://bugs.gentoo.org/60132
|
|
|
|
---
|
|
manual/Makefile | 5 +++++
|
|
1 file changed, 5 insertions(+)
|
|
|
|
--- a/manual/Makefile
|
|
+++ b/manual/Makefile
|
|
@@ -106,9 +106,14 @@
|
|
libm-err.texi: stamp-libm-err
|
|
stamp-libm-err: libm-err-tab.pl $(wildcard $(foreach dir,$(sysdirs),\
|
|
$(dir)/libm-test-ulps))
|
|
+ifneq ($(PERL),no)
|
|
pwd=`pwd`; \
|
|
$(PERL) $< $$pwd/.. > libm-err-tmp
|
|
$(move-if-change) libm-err-tmp libm-err.texi
|
|
+else
|
|
+ echo "Unable to rebuild math docs, no perl installed"
|
|
+ touch libm-err.texi
|
|
+endif
|
|
touch $@
|
|
|
|
# Generate Texinfo files from the C source for the example programs.
|